Resolved
The Global Microsoft 365 Outage seems to be on its way to being resolved. As a result, the Drumkit sidebar should be live and available for most if not all users. Thank you!
Monitoring
Microsoft has notified us that they believe they have deployed a partial resolution. We will begin to see some improvements and continue to update here as we get updates.
Investigating
We are currently experiencing a critical service interruption that is affecting the ability to access Drumkit. There is currently a major outage that Microsoft 365 is encountering, and that has impacted us.
We understand how disruptive this is, and we sincerely apologize for the impact on your workflow.
Impact: Users are currently unable to access core Drumkit functionality in Outlook.
Start Time: The issue began at approximately 12:10 PM EDT.
Root Cause: This incident is related to a major outage currently affecting Microsoft 365. While the core Drumkit application is stable, this outage is preventing users from accessing functionality.
Our engineering team is actively engaged, monitoring the Microsoft 365 recovery status, and exploring all possible mitigation strategies, including implementing workarounds where possible.
We are treating this with the highest priority and are focused on restoring email processing as quickly as possible.
We will be providing real-time updates via email and on this page.