12/1 Drumkit Sidebar White Screen Upon Login
Resolved·Partial outage

We are pleased to confirm that the partial outage causing some users to see white screens upon logging into Drumkit has been fully resolved.

All monitoring systems show Drumkit functionality operating at full stability and capacity. No user data was compromised or lost during this event. We kindly ask all users to refresh their Outlook application/browser and confirm that all Drumkit functionality is now accessible.

If you continue to see any issues, re-authenticating your Drumkit account at drumkit.ai/relink may additionally resolve the issue.

Thank you again for your patience and understanding. We sincerely apologize for the disruption this external outage caused to your day. Please let us know if you have any other intermittent issues by reaching out to support@drumkit.ai.

Mon, Dec 1, 2025, 03:39 PM
(4 days ago)
·
Affected components
Sidebar
Updates

Resolved

We are pleased to confirm that the partial outage causing some users to see white screens upon logging into Drumkit has been fully resolved.

All monitoring systems show Drumkit functionality operating at full stability and capacity. No user data was compromised or lost during this event. We kindly ask all users to refresh their Outlook application/browser and confirm that all Drumkit functionality is now accessible.

If you continue to see any issues, re-authenticating your Drumkit account at drumkit.ai/relink may additionally resolve the issue.

Thank you again for your patience and understanding. We sincerely apologize for the disruption this external outage caused to your day. Please let us know if you have any other intermittent issues by reaching out to support@drumkit.ai.

Mon, Dec 1, 2025, 03:39 PM

Investigating

Hello,

We are currently experiencing a partial service interruption that is affecting the ability to access Drumkit. Some users are seeing a blank white screen upon login into Drumkit.

We understand how disruptive this is, and we sincerely apologize for the impact on your workflow.

Solution
  • Workaround: Users facing this issue may be able to resolve this by going to http://drumkit.ai/relink and logging back into their associated Drumkit account via Google or Microsoft.

What We Know
  • Impact: Users are currently unable to access core Drumkit functionality in Outlook.

  • Start Time: The issue began at approximately 8:40 AM EDT.

  • Root Cause: This incident is related to a authentication upgrade behind the scenes. While the core Drumkit application is stable, this outage is preventing users from accessing functionality.

Our Action Plan

Our engineering team is actively engaged and exploring all possible mitigation strategies.

We are treating this with the highest priority and are focused on restoring access as quickly as possible.

Next Steps and Updates

We will be providing updates via email and on our dedicated Status Page, which is built on separate infrastructure to remain accessible during external outages.

Thank you for your patience as we navigate this issue.

Mon, Dec 1, 2025, 02:22 PM(1 hour earlier)